Задать вопрос
30 сентября, 16:55

Три точки А (х₁; у₁), В (х₂; у₂), С (х₃; у₃) задаются своими координатами. Написать программу, которая определяет, какая из этих точек ближе к началу координат.

+3
Ответы (1)
  1. 30 сентября, 18:42
    0
    Var

    x1, x2, x3, y1, y2, y3, r1, r1, r3: real;

    begin

    writeln ('введите координаты A') ;

    readln (x1, y1) ;

    writeln ('введите координаты B') ;

    readln (x2, y2) ;

    writeln ('введите координаты C') ;

    readln (x3, y3) ;

    r1:=sqrt (x1*x1+y1*y1) ;

    r2:=sqrt (x2*x2+y2*y2) ;

    r3:=sqrt (x3*x3+y3*y3) ;

    if (r1<=r2) and (r1<=r3) writeln ('точка А ближе') ;

    if (r2<=r1) and (r2<=r3) writeln ('точка B ближе') ;

    if (r3<=r1) and (r3<=r2) writeln ('точка C ближе') ;

    readln;

    end
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Три точки А (х₁; у₁), В (х₂; у₂), С (х₃; у₃) задаются своими координатами. Написать программу, которая определяет, какая из этих точек ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
1. Написать программу для решения задачи: Точки на плоскости заданы своими координатами. Определить какая из них находится ближе к началу координат.
Ответы (1)
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.
Ответы (1)
Нужно подробное написание программы в pascalABC 1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
Ответы (1)