Задать вопрос
16 мая, 17:55

1.

Написать

программу для решения задачи: Точки на плоскости

заданы своими координатами. Определить какая из них находится ближе к началу

координат.

+2
Ответы (1)
  1. 16 мая, 19:00
    0
    Uses crt;

    var n, minind, i:integer;

    min, x, y:real;

    begin

    writeln ('Введите количество точек: ') ;

    read (n) ;

    writeln ('Вводите по очереди координаты x и y точек.') ;

    read (x, y) ;

    min:=sqr (x) + sqr (y) ;

    minind:=1;

    for i:=2 to n do

    begin

    read (x, y) ;

    if sqr (x) + sqr (y)
    begin

    min:=sqr (x) + sqr (y) ;

    minind:=i;

    end;

    end;

    writeln ('Точка под номером ', minind,'.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Написать программу для решения задачи: Точки на плоскости заданы своими координатами. Определить какая из них находится ближе к началу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы