Задать вопрос
25 июня, 17:39

Составить программу на языке паскаль:

Две точки задаются своими координатами. Определите, какая из них находится дальше от:

начала координат;

окружности заданного радиуса с центром в начале координат.

+4
Ответы (1)
  1. 25 июня, 18:01
    0
    Program gt;

    var x1, y1, x2, y2, r:real;

    begin

    readln (x1, y1, x2, y2) ;

    readln (r) ;

    if ((sqr (x1) + sqr (y1)) < (sqr (x2) + sqr (y2))) then writeln ('Pervaya') else

    writeln ('2-raya') ;

    if (abs (sqrt (sqr (x1) + sqr (y1)) - r)
    then writeln ('Pervaya-ornositelno okru') else writeln ('2-raya otnositelno okru') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы