Задать вопрос
11 апреля, 08:40

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

+5
Ответы (1)
  1. 11 апреля, 12:28
    0
    может быть так:

    var x1, x2, y1, y2:integer;

    a, b:real;

    begin

    write ('Введите x1 и x2: ') ;

    readln (x1, x2) ;

    write ('Введите y1 и y2: ') ;

    readln (y1, y2) ;

    a:=sqrt (sqr (x1) + sqr (y1)) ;

    b:=sqrt (sqr (x2) + sqr (y2)) ;

    if a>b then writeln ('1-я точка ближе')

    else writeln ('2-я точка ближе') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы