Задать вопрос
10 ноября, 22:30

Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. Напишите программу, определяющую победителя

+1
Ответы (1)
  1. 11 ноября, 02:20
    0
    Var A, B:byte;

    S, Sa, Sb:integer;

    Begin

    WriteLn ('S = ') ; ReadLn (S) ;

    Repeat

    Write ('A = ') ; ReadLn (A) ;

    Sa:=Sa+A;

    Write ('B = ') ; ReadLn (B) ;

    Sb:=Sb+B;

    Until (Sa>=S) or (Sb>=S) ;

    if (A>B) then WriteLn ('Победил игрок A')

    else WriteLn ('Победил игрок B')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы