Задать вопрос
18 января, 01:55

Дана последовательность чисел А длины N. Требуется вывести в обратном порядке.

Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину

последовательности. Вторая строка входного файла содержит N целых чисел - элементы

последовательности A. Все элементы последовательности не превосходят 100000 по

абсолютному значению.

В единственной строке выходного файла выведите элементы последовательности A в

обратном порядке. Для наглядности обратите внимание на примеры.

+5
Ответы (1)
  1. 18 января, 03:42
    0
    Var

    a: array of - 100000 ... 100000;

    n, i: longint;

    input, output : text;

    begin

    assign (input, 'input. txt') ;

    assign (output, 'output. txt') ;

    reset (input) ;

    rewrite (output) ;

    readln (input, n) ;

    setLength (a, n) ;

    for i:=0 to n-1 do read (input, a[i]) ;

    for i:=n-1 downto 0 do write (output, a[i]) ;

    close (input) ; close (output) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Первая строка входного файла содержит целое число N (1 < = N ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)
Формат входного и выходного файла На первой строке входного файла находятся два целых числа a и b (-109 ≤ a, b ≤ 109 ). Вашей программе требуется вывести единственное число - сумму заданных чисел a + b.
Ответы (1)