Задать вопрос
11 августа, 23:20

Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.

+5
Ответы (1)
  1. 12 августа, 00:07
    0
    Program Pr1;

    uses crt;

    var mas:array[byte] of integer;

    fl1, fl2:text;

    stroka:string;

    b, v, c, max, i:integer;

    Begin

    clrscr;

    assign (fl1,'E. in') ;

    assign (fl2,'E. out') ;

    reset (fl1) ;

    readln (fl1, stroka) ;

    close (fl1) ;

    for i:=1 to length (stroka) do val (stroka[i], mas[i], b) ;

    b:=length (stroka) ;

    max:=1;

    v:=0;

    for i:=1 to b do if mas[i]>v then if mas[i]>max then max:=mas[i]

    else v:=mas[i];

    c:=max*v;

    rewrite (fl2) ;

    writeln (fl2, c) ;

    close (fl2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Дается последовательность из N чисел. Найдите максимальное произведение среди всех пар этих чисел. Первая строка входного файла содержит целое число N (1
Ответы (1)
Формат входного и выходного файла На первой строке входного файла находятся два целых числа a и b (-109 ≤ a, b ≤ 109 ). Вашей программе требуется вывести единственное число - сумму заданных чисел a + b.
Ответы (1)
Помогитее это на паскале имя входного файла: A. in имя выходного файла: A. out ограничение по времени 2 секунды ограничение по памяти 64 мегабайт пример A. in 13 5 A. out A>B комментарии 13>5
Ответы (1)
Суммаипроизведение Имя входного файла: Имя выходного файла: Ограничение по времени: Ограничение по памяти: standard input standard output 1 секунда 64 мегабайта Найдите сумму и произведение двух чисел.
Ответы (1)