Задать вопрос
19 июля, 13:27

Составьте программу, которая запрашивает три целых числа и, если ни одно из чисел не равно нулю, выводит на экран их среднее арифметическое.

+1
Ответы (1)
  1. 19 июля, 13:52
    0
    Program d;

    var a, b, c:integer;

    Begin

    Writeln ('введите 3 целых числа через пробел') ; Read (a, b, c) ;

    if (a0) and (b0) and (c0) then writeln ((a+b+c) / 3)

    else writeln ('одно из чисел равно нулю') ;

    Readln;

    end.

    Проверил - все работает. Если возникнут вопросы - пиши в личку.

    Удачи!
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая запрашивает три целых числа и, если ни одно из чисел не равно нулю, выводит на экран их среднее арифметическое. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы