Задать вопрос
19 июля, 17:28

Составьте программу которая заполняет массив а [1 ... 8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями

+3
Ответы (1)
  1. 19 июля, 19:21
    0
    Var

    a : array [1 ... 8] of integer;

    i, count, sum : integer;

    begin

    randomize;

    for i : = 1 to 8 do

    a[i] : = random (10) + 1;

    count : = 0; sum : = 0;

    for i : = 1 to 8 do

    if a[i] mod 2 = 0 then count : = count + 1

    else sum : = sum + a[i];

    writeln ('count = ', count) ;

    writeln ('sum = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу которая заполняет массив а [1 ... 8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы