Задать вопрос
23 марта, 11:03

56) Получив на вход число х, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.

var x, a, b: integer;

begin

readln (x) ;

a : = 0; b : = 0;

while x > 0 do begin

a : = a+1;

b : = b + (x mod 100) ;

x : = x div 100;

end;

writeln (a) ; write (b) ;

end.

+3
Ответы (1)
  1. 23 марта, 11:44
    0
    Наибольший х - 1500.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «56) Получив на вход число х, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел х, при вводе которых алгоритм ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы