Задать вопрос
22 января, 11:15

Дано четырехзначное число. Написать программу, которая определяет равна ли сумма первых двух его цифр сумме двух его последних цифр.

+5
Ответы (2)
  1. 22 января, 12:15
    0
    var

    a, a1, a2: integer;

    begin

    read (a) ;

    a1 : = a div 1000 mod 10 + a div 100 mod 10;

    a2 : = a div 10 mod 10 + a mod 10;

    writeln (a1 = a2) ;

    end.
  2. 22 января, 12:29
    0
    var

    a, a1, a2, a3, a4:integer;

    begin

    readln (a) ;

    a1:=a div 1000;

    a2:=a div 100 mod 10;

    a3:=a div 10 mod 10;

    a4:=a mod 10;

    if (a1+a2) = (a3+a4) then writeln ('Равена')

    else

    writeln ('Не равна') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырехзначное число. Написать программу, которая определяет равна ли сумма первых двух его цифр сумме двух его последних цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Дано четырехзначное число. определить равна ли сумма первых двух его цифр сумме двух его последних цифр. В паскале
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)