Задать вопрос
21 апреля, 19:43

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом.

8 класс.

+4
Ответы (1)
  1. 21 апреля, 20:00
    0
    1)

    var a: integer;

    begin

    write ('Введите число: ') ;

    read (a) ;

    if (a div 10 + a mod 10 + a div 10 mod 10) mod 2 = 0

    then writeln ('Сумма цифр четна')

    else writeln ('Сумма цифр нечетна')

    end.

    2)

    var a: integer;

    begin

    write ('Введите число: ') ;

    read (a) ;

    if a mod 2 = 0 then writeln ('Последняя цифра числа четная')

    else writeln ('Последняя цифра числа нечетная')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы