Задать вопрос
26 февраля, 10:17

47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя

48 дано целое четырехзначное положительное число n. составьте программу, которая определяет, кратно ли пяти произведение его цифр

+3
Ответы (1)
  1. 26 февраля, 10:58
    0
    var

    n:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    if (n mod 10) > ((n div 100) mod 10) then

    writeln ('Последняя больше второй')

    else

    if (n mod 10) < ((n div 100) mod 10) then

    writeln ('Вторая больше последней')

    else

    writeln ('Они равны') ;

    readln;

    end.

    / / Вторая программа

    var

    n, Pr:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    Pr : = 1;

    while n > 0 do

    begin

    Pr : = Pr * (n mod 10) ;

    n : = n div 10;

    end;

    writeln ('Pr = ', Pr) ;

    if Pr mod 5 = 0 then

    writeln ('Кратно')

    else

    writeln ('Некратно') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы