Задать вопрос
20 июля, 21:44

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот период. Прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0).

На входе программа получает период N

+1
Ответы (1)
  1. 21 июля, 00:54
    0
    через генератор случайных чисел

    program noname;

    uses crt;

    var

    n, k, i:integer;

    a:array[1 ... 1000] of longint;

    max:longint;

    begin

    clrscr;

    write ('vvedi period n=') ;

    readln (n) ; k:=0;

    for i:=1 to n do begin

    randomize;

    a[i]:=random (10000) ;

    writeln (a[i]) ;

    if a[i]-1000<0 then k:=k+1;

    end;

    max:=a[1];

    for i:=2 to n do

    if max
    writeln (k,'-дни без прибыли ', max,'-максимальная выручка') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы