Задать вопрос
13 февраля, 12:21

Дается последовательность из N чисел. Найдите максимальное произведение среди всех пар этих чисел.

Первая строка входного файла содержит целое число N (1<=N<=1000). В следующей строке задаются N целых чисел, каждое из которых по модулю меньше или равно 1000.

+2
Ответы (1)
  1. 13 февраля, 16:06
    0
    Var ar:array of integer;

    max, i, n, j:integer;

    begin;

    max:=-2147483648; / / нижняя граница integer

    writeln ('Введите размерность массива:') ; / / массив всегда приятнее

    readln (n) ;

    setlength (ar, n+1) ; / / задали размерность динамического массива

    for i:=1 to n do

    begin;

    write ('Введите ', i, ' элемент массива:') ;

    readln (ar[i]) ;

    end;

    for i:=1 to n do

    for j:=1 to n do

    if max
    writeln ('Result:', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дается последовательность из N чисел. Найдите максимальное произведение среди всех пар этих чисел. Первая строка входного файла содержит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы