Задать вопрос
24 сентября, 10:31

n factorial это произведение всех чисел от 1 до n. Для заданного числа n определите, сколько нулей в конце десятичной записи n factorial.

+5
Ответы (1)
  1. 24 сентября, 11:33
    0
    Program 1;

    var n, k2, k5, i, a:integer;

    begin

    write ('n=') ;

    read (n) ;

    k2:=0; k5:=0;

    for i:=2 to n do begin a:=i;

    if a mod 2=0 then while a>=2 do

    begin

    a:=a div 2;

    k2:=k2+1;

    end;

    a:=i;

    if a mod 5=0 then while a>=5 do begin a:=a div 5;

    k5:=k5+1; end; end;

    if k2
    write (k5) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «n factorial это произведение всех чисел от 1 до n. Для заданного числа n определите, сколько нулей в конце десятичной записи n factorial. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы