Задать вопрос
24 сентября, 12:09

Cтроки. Паскаль.

1. Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному (символы записываются в обратной последовательности.)

2. Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя. составить программу, в которой выводились бы все слова, в которых есть заданный символ.

+5
Ответы (1)
  1. 24 сентября, 12:32
    0
    {Первая задача}

    var

    s, rez: string; / / строки

    i: integer; / / целое число (счетчик)

    begin

    writeln ('Введите строку:') ;

    readln (s) ; / /

    for i : = length (s) downto 1 do / / просматриваем буквы, начиная с последней

    rez : = rez + s[i]; / / прибавляем букву к результату

    writeln (rez) / / выводим результат

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Cтроки. Паскаль. 1. Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы