Задать вопрос
19 апреля, 18:52

Для того чтобы выходить в Интернет, каждому компьютеру присваивается так называемый IP-адрес. Он состоит из четырех целых чисел в диапазоне от 0 до 255, разделенных точками. В следующих трех строках показаны три правильных IP-адреса:

127.0.0.0

192.168.0.01

255.00.255.255

Напишите программу, которая определяет, является ли заданная строка правильным IP-адресом.

Формат входного файла:

На вход программе подается строка длиной не более 15 символов, которая включает цифры и ровно три точки.

Формат выходного файла:

Если строка является правильным IP-адресом, необходимо вывести 1, иначе 0.

+2
Ответы (1)
  1. 19 апреля, 19:44
    0
    Program ip;

    var s, s1:string;

    i, j, x, err:integer;

    f:boolean;

    begin

    readln (s) ;

    i:=1; j:=1; f:=true;

    while (j<4) and f do

    begin

    while s[i]'.' do

    begin

    s1:=s1+s[i];

    inc (i) ;

    end;

    val (s1, x, err) ;

    f:=x<256;

    delete (s1,1, length (s1)) ;

    inc (j) ;

    end;

    if f then

    begin

    while i<=length (s1) do

    begin

    s1:=s1+s[i];

    inc (i) ;

    end;

    f:=x<256;

    end;

    if f then writeln (1) else writeln (0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Для того чтобы выходить в Интернет, каждому компьютеру присваивается так называемый IP-адрес. Он состоит из четырех целых чисел в диапазоне ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы