Задать вопрос
7 апреля, 17:38

Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.

+4
Ответы (1)
  1. 7 апреля, 19:29
    0
    var t:array[0 ... 19] of byte;

    i, k, l, s:integer;

    begin

    k:=0;

    l:=0;

    s:=0;

    for i:=0 to 19 do begin

    t[i]:=random (21) - 10;

    write (t[i],' ') ;

    if t[i]=0 then k:=k+1;

    if t[i] mod 3=0 then s:=s+t[i];

    l:=l+t[i];

    end;

    write ('колво 0 ', k) ;

    write ('сумма кратных 3 ', s) ;

    write ('средне арефм ', l/20) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы