Задать вопрос
22 апреля, 01:51

Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу.

+3
Ответы (1)
  1. 22 апреля, 02:22
    0
    var i:word; переменная через которую будут проходить все трехзначные цифры

    s:longint; переменная для хранения суммы

    begin

    s:=0; -обнуляем переменную где будем сохранять сумму

    write ('Числа: ') ;

    for i:=100 to 999 do начинаем перебор всех трехзначных цифр

    if i mod 2 = 0 then проверка на четность, мод - это деление по остатку, т. е в ответ записывается остаток от деления

    if i mod 7 = 0 then begin write (i,' ') ; s:=s+i; end; выводим четное число кратное 7 и в тоже время суммируем его с последующими четными кратных 7 ми, в переменной s

    writeln; пропускаем строку

    writeln ('Сумма всех всех четных трехзначных чисел, которые делятся на 7 = ', s) ; выводим на экран результат

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы