Задать вопрос
22 апреля, 03:38

Составьте программу в Паскале для проверки утверждения: "Результатами вычислений по формуле х²+х+41 при 0<х<40 являются простые числа". Все результаты вывести на экран.

+2
Ответы (1)
  1. 22 апреля, 07:09
    0
    Var A, x, d, k, p:integer;

    Begin

    WriteLn ('f (x) = x^2 + x + 41') ;

    p:=0;

    For x: = 1 to 39 do

    Begin

    A:=x*x+x+41;

    Write ('f (', x,') = ', A) ;

    d:=2;

    k:=0;

    While (A0) and (d
    Begin

    if A mod d = 0 then k:=k+1;

    d:=d+1

    End;

    if k = 0 then WriteLn (' - простое')

    else

    Begin

    WriteLn (' - не является простым') ;

    p:=1;

    End

    End;

    if p = 0 then WriteLn ('Все полученные числа - простые')

    else WriteLn ('Не все полученные числа являются простыми') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу в Паскале для проверки утверждения: "Результатами вычислений по формуле х²+х+41 при 0 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы