Задать вопрос
26 октября, 06:05

Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0

Используя цикл repeat

+2
Ответы (1)
  1. 26 октября, 07:38
    0
    Var

    A, S, P:real;

    k:integer;

    Begin

    S:=0;

    P:=1;

    k:=-1;

    Repeat

    Read (A) ;

    if A 0 then P:=P*A;

    S:=S+A;

    k:=k+1;

    Until A = 0;

    WriteLn ('P = ', P) ;

    WriteLn ('Sr = ', S/k) ;

    ReadLn

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0 Используя цикл ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы