Задать вопрос
14 августа, 14:41

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа

+3
Ответы (1)
  1. 14 августа, 14:50
    0
    Program prog;

    uses crt;

    var x, y:integer;

    begin

    clrscr;

    write ('x = ') ;

    readln (x) ;

    while abs (x) >0 do begin

    if abs (x mod 10) >y then y: = abs (x mod 10) ;

    x: = x div 10;

    end;

    writeln ('Наибольшая цифра чсла = ', y) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы