Задать вопрос
26 августа, 09:19

Ребят, жду помощи

Нужно написать программу на паскале

1) Вводи 2 слова

2) Программа пишет что 1 слово - n символов, 2 слово - n символов, а пробел символ номер N

3) Программа пишет 1 слово, а за ним первый символ 2 слова.

На этом все

+3
Ответы (1)
  1. 26 августа, 09:41
    0
    Uses crt;

    var

    a:string;

    i, n:integer;

    begin

    clrscr;

    writeln ('Введи 2 слова через пробел') ;

    readln (a) ;

    n:=pos (' ', a) ;

    writeln ('1 слово ', n-1,' символов') ;

    writeln ('2 слово ', length (a) - n,' пробел - символ № ', n) ;

    for i:=1 to n-1 do

    write (a[i]) ;

    write (a[n+1]) ;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ребят, жду помощи Нужно написать программу на паскале 1) Вводи 2 слова 2) Программа пишет что 1 слово - n символов, 2 слово - n символов, а ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Пользователь-Человек в твою программу вводит два числа А программа ему пишет, какое из них больше написать программу в Паскале.
Ответы (1)
Помогите составить программу в Pascal ABC Составить программу, которая определяет: a) символ по его коду, введенному с клавиатуры; b) символ для кода 100; c) код для символа ' ' (пробел).
Ответы (1)