Задать вопрос
1 апреля, 01:34

Напишите программу которая выводит на экран столбец матрицы, сумма значений элементов которая наименьшая

+4
Ответы (1)
  1. 1 апреля, 02:30
    0
    Const nx=30; mx=30;

    var r:array[1 ... nx, 1 ... mx] of integer; b:array[1 ... mx] of integer;

    i, j, n, m, k, sum, min:integer;

    begin

    min:=40;

    randomize;

    write ('Введите n, m: ') ; readln (n, m) ;

    writeln ('Исходная матрица: ') ;

    for j:=1 to m do begin

    for i:=1 to n do begin

    r[i, j]:=random (20) - 10;

    sum: = sum + r[i, j]; end;

    b[j]:=sum; sum:=0;

    end;

    for i:=1 to n do begin

    for j:=1 to m do begin

    write (r[i, j]:4) ; end;

    writeln; end;

    writeln;

    for j:=1 to m do begin

    write (b[j]:4) ;

    if min > b[j] then begin

    min: = b[j]; k: = j; end;

    end;

    writeln; writeln;

    for i:=1 to n do begin

    for j:=1 to m do begin

    if j=k then write (r[i, j]:4) ; end;

    writeln; end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая выводит на экран столбец матрицы, сумма значений элементов которая наименьшая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)
Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец.
Ответы (1)