Задать вопрос
20 апреля, 07:07

найдите сумму нечётных отрицательных чисел на промежутке [-36; 36] делящихся на 7

(составить программу)

+3
Ответы (1)
  1. 20 апреля, 08:31
    0
    Program p1;

    const n=10;

    var a: array [1 ... n] of integer;

    s, i: integer;

    begin

    randomize;

    for i: = 1 to n do

    begin

    a[i]: = random (73) - 36

    ; write (a[i]:3) ;

    end;

    s:=0;

    for i:=1 to n do

    begin

    if (a[i] mod 20) and (a[i] mod 7=0) then

    begin

    s:=s+a[i];

    end;

    end;

    writeln;

    writeln ('сумма=', s) ;

    end.

    единственное не учел момент когда таких числе нет, можете дописать
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «найдите сумму нечётных отрицательных чисел на промежутке [-36; 36] делящихся на 7 (составить программу) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы