Задать вопрос
9 июня, 00:23

3. Написать программу вычисления xy, не используя функцию возведения в степень (только цикл). X, y вводятся с клавиатуры

+5
Ответы (2)
  1. 9 июня, 03:02
    0
    Тривиальное решение.

    var

    i, r, x, y:integer;

    begin

    Write ('Вычисление х в степени y, введите х, y: ') ;

    Readln (x, y) ;

    r:=x;

    for i:=2 to y do r:=r*x;

    Writeln ('Результат: ', r)

    end.

    Тестовый прогон:

    Вычисление х в степени y, введите х, y: 2 10

    Результат: 1024

    Вариант для любителей начинать циклы с единицы.

    var

    i, r, x, y:integer;

    begin

    Write ('Вычисление х в степени y, введите х, y: ') ;

    Readln (x, y) ;

    r:=1;

    for i:=1 to y do r:=r*x;

    Writeln ('Результат: ', r)

    end.
  2. 9 июня, 04:06
    0
    Var x, y, p:integer;

    begin

    read (x, y) ;

    p:=x;

    for y:=y downto 2 do

    p*=x;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «3. Написать программу вычисления xy, не используя функцию возведения в степень (только цикл). X, y вводятся с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы