Задать вопрос
8 мая, 08:18

Написать программу, которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов расположенных в левом верхнем углу матрицы и правом нижним? Pascal

+1
Ответы (1)
  1. 8 мая, 11:08
    0
    Осталось понять что подразумевалось под словом угол.

    Ну допустим что угол это одна самая угловая ячейка

    var

    a: array [1 ... 20,1 ... 20] of Integer;

    i, j, n, sum:Integer;

    begin

    Writeln ('Введмте размер двумерного массива (2<=n<=20) ') ;

    ReadLn (n) ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=Random (20) ;

    Write (a[i, j]:3) ;

    end;

    WriteLn () ;

    end;

    sum:=a[1,1]+a[n, n];

    WriteLn ('Сумма значений элементов расположенных в левом верхнем и в правом нижнем углах = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы