Задать вопрос
2 января, 19:57

Составить программу вычисления произведения положительных и суммы отрицательных элементов массива A. проверить работу программы на заданном массиве A (11).

На паскале

+2
Ответы (1)
  1. 2 января, 23:13
    0
    Program p1;

    uses crt;

    var a:array[1 ... 11] of integer;

    i, p, s:integer;

    begin

    for i:=1 to 11 do begin

    a[i]:=random (30) - 10;

    write (a[i]:4) ;

    end;

    p:=1;

    s:=0;

    for i:=1 to 11 do begin

    If a[i]>0 then begin

    p:=p*a[i];

    end;

    If a[i]<0 then

    s:=s+a[i];

    end;

    writeln;

    writeln ('Произведение : ', p) ;

    writeln ('Сумма : ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления произведения положительных и суммы отрицательных элементов массива A. проверить работу программы на заданном ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы