Задать вопрос
14 ноября, 02:10

Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N

pascal

+1
Ответы (1)
  1. 14 ноября, 05:40
    0
    Var i, j, n, p: integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    begin

    p : = 0;

    for j : = i - 1 downto 1 do

    if (i mod j = 0) then p : = p + j;

    if p = i then writeln (i, ' - совершенное число') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N pascal ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы