Задать вопрос
16 февраля, 05:51

Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto)

+5
Ответы (1)
  1. 16 февраля, 07:44
    0
    var

    a, b, c, x1, x2, d:real;

    begin

    write ('Введите A=') ; readln (a) ;

    write ('Введите B=') ; readln (b) ;

    write ('Введите C=') ; readln (c) ;

    D:=b*b-4*a*c;

    if D<0 then begin

    writeln ('Нет корней') ;

    end;

    if D=0 then begin

    writeln ('x1=',-b / (2*a))

    end;

    if D>0 then begin

    x1: = (-b-sqrt (d)) / (2*a) ;

    x2: = (-b+sqrt (d)) / (2*a) ;

    writeln ('x1=', x1) ;

    writeln ('x2=', x2) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы