Задать вопрос
16 февраля, 07:43

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отриц

+2
Ответы (1)
  1. 16 февраля, 07:59
    0
    Var a, b, p, n:integer;

    begin

    writeln ('Введите два числа:') ;

    readln (a, b) ;

    n:=abs (b) ;

    if (a=0) or (b=0) then

    writeln (a,'*', b,'=0')

    else begin

    while (n0) do begin

    n:=n-1;

    p:=p+abs (a)

    end;

    if (a>0) and (b>0) then writeln (a,'*', b,'=', p) ;

    if (a<0) and (b<0) then writeln (' (', a,') ','*',' (', b,') ','=', p) ;

    if (a>0) and (b<0) then writeln (a,'*',' (', b,') ','=-', p) ;

    if (a0) then writeln (' (', a,') ','*', b,'=-', p) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы