Задать вопрос
6 августа, 07:29

Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива. Все числа по модулю не превосходят 10000

Формат выходных данных Выведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], ...).

+3
Ответы (1)
  1. 6 августа, 08:37
    0
    Вот массив который сам заполняется

    uses crt;

    const

    n=100;

    var

    i, a:integer;

    mas1: array [0 ... n] of integer;

    begin

    for i:=0 to n do

    begin

    a:=random (10000) ;

    mas1[i]:=a;

    end;

    for i:=0 to n do

    begin

    if i mod 2=0 then

    write ('A[', i,']=', mas1[i],' ') ;

    end;

    end.

    вот заполняемый вручную (чтобы записывать через пробел сам измени)))

    uses crt;

    const

    n=100;

    var

    i, a:integer;

    mas1: array [0 ... n] of integer;

    label 1;

    begin

    for i:=0 to n do

    begin

    1:read (a) ;

    if a<=10000 then

    mas1[i]:=a

    else

    begin

    writeln ('a bolwe 10000') ;

    goto 1

    end;

    end;

    for i:=0 to n do

    begin

    if i mod 2=0 then

    write ('A[', i,']=', mas1[i],' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы