Задать вопрос
14 апреля, 09:30

На языке программирования Паскаль напишите программу, которая:

1) В последовательности чисел находит количество чисел, кратных 3.

2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.

+4
Ответы (1)
  1. 14 апреля, 09:47
    0
    1)

    program kr3sum;

    var i, s. h:integer;

    begin

    read (k) / / кол чисел

    for i:=1 to k do begin

    read (h) / / число для действий

    if h mod 3 = 0 then begin s:=s+1;

    end;

    writeln (s) ;

    end.

    2)

    program jeje;

    var k, i, m, s, h:integer;

    begin m:=0;

    read (k) ; / / кол-во чисел

    for i:=1 to k do begin

    readln (h) ;

    if h mod 10 = 4 then begin s:=h;

    if s > m then m:=s

    end;

    end;

    write (m) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы