Задать вопрос
14 апреля, 06:39

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму

+4
Ответы (1)
  1. 14 апреля, 10:24
    0
    Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение).

    var

    sum, mul, i : integer;

    begin

    sum : = 0; mul : = 1;

    for i : = 1 to 50 do

    if i mod 9 = 0 then

    begin

    write (i, ' ') ;

    sum : = sum + i;

    mul : = mul * i;

    end;

    writeln;

    writeln ('sum = ', sum) ;

    writeln ('mul = ', mul) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы