Задать вопрос
14 ноября, 07:07

Написать программу:

Даны длины сторон треугольника a, b, c. Является ли он прямоугольным?

+4
Ответы (1)
  1. 14 ноября, 08:15
    0
    Var a, b, c, t:real;

    begin

    readln (a, b, c) ;

    if b>a then begin

    t:=a;

    a:=b;

    b:=t;

    end;

    if c>a then begin

    t:=a;

    a:=c;

    c:=t;

    end;

    if (a*a=b*b+c*c) then writeln ('Треугольник прямоугольный') else writeln ('Треугольник не прямоугольный') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу: Даны длины сторон треугольника a, b, c. Является ли он прямоугольным? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы