Задать вопрос
22 марта, 11:55

Помогите написать программу в Паскале.

Дан массив размера N.

1. Найти количество участков К, на которых его элементы монотонно возрастают.

+2
Ответы (1)
  1. 22 марта, 13:58
    0
    Const n=20;

    var a:array[1 ... n] of integer;

    i, k, m:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) ;

    write (a[i]:3) ;

    end;

    writeln;

    k:=0; m:=0;

    for i:=1 to n-1 do

    begin

    if a[i+1]>a[i] then begin m:=m+1; end

    else begin if m>0 then k:=k+1; m:=0; end;

    end;

    if m>0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Массив A:

    7 30 22 0 17 4 2 32 39 26 23 41 1 38 47 21 38 31 43 7

    k = 7
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскале. Дан массив размера N. 1. Найти количество участков К, на которых его элементы монотонно возрастают. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы