Задать вопрос
22 декабря, 11:02

Дано два натуральных числа N и M.

Написать программу для определения

наименьшего из чисел, составленных из цифр данных чисел. Незначащих

нулей в найденном числе быть не должно.

Формат входных данных:

Входной

файл input. txt содержит два натуральных числа N (10 < = N <=

10^100) и M (10 < = M < = 10^100), разделенных одним пробелом.

Формат выходных данных:

Выходной файл output. txt должен содержать найденное наименьшее число.

+2
Ответы (1)
  1. 22 декабря, 11:33
    0
    Var x, y:longint;

    g, f: text;

    begin

    assign (g, 'input. txt') ;

    assign (f, 'output. txt') ;

    reset (g) ;

    read (g, x, y) ;

    close (g) ;

    rewrite (f) ;

    if x
    if x>y then write (f, y) ;

    close (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано два натуральных числа N и M. Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы