Задать вопрос
7 августа, 16:43

Работа с Паскаль

Помогите

Задание: Даны координаты точки на плоскости (x, y). Выясните, лежит ли эта точка внутри квадрата, две стороны которого лежат на положительных ветвях осей координат. Длина стороны квадрата равна 5.

+1
Ответы (1)
  1. 7 августа, 17:55
    0
    {т. е. квадрат лежит на оси x начиная от 0 до 5, т. к. сторона квадрата = 5, аналогично и с осью y, отсюда условия x>=0 x=0 y<=5}

    var

    x, y:real;

    begin

    readln (x, y) ;

    if (x>0) and (x0) and (y<5) then

    writeln ('попадает')

    else

    writeln ('не попадает') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Работа с Паскаль Помогите Задание: Даны координаты точки на плоскости (x, y). Выясните, лежит ли эта точка внутри квадрата, две стороны ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача pascal Даны целочисленные координаты точки на плоскости. Если точка совпадает с началом координат, то вывести 0. Если точка не совпадает с началом координат, но лежит на оси ОХ или OY, то вывести соответственно 1 или 2.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные данные Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Ответы (1)
Delphi На плоскости задана прямоугольная система координат с осями Х и У. Составить программу которая вводит координаты точки (х, у) и сообщает принадлежит ли эта точка кругу с центром в начале координат и радиусом r или лежит на границу его
Ответы (1)