Задать вопрос
6 апреля, 00:03

Помогите написать программу в Паскале.

Ввести с клавиатуры 6 произвольных чисел. Вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5. (Остаток на деление на 10 равен 5).

+2
Ответы (1)
  1. 6 апреля, 03:28
    0
    Var i, x, count: integer;

    sum: real;

    begin

    sum : = 0;

    count : = 0;

    for i : = 1 to 6 do

    begin;

    writeln ('Введите число') ;

    readln (x) ;

    if (x mod 4 = 0) or (x mod 10 = 5) then

    begin;

    sum : = sum + x;

    count : = count + 1;

    end;

    end;

    writeln (sum/count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскале. Ввести с клавиатуры 6 произвольных чисел. Вычислить среднее арифметическое тех чисел, которые ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы