Задать вопрос
17 октября, 06:09

Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N

+1
Ответы (1)
  1. 17 октября, 09:54
    0
    Var

    i, n, s, k: integer;

    begin

    readln (n) ;

    for i : = 100 to 999 do

    begin

    s : = 0; k : = i;

    while k > 0 do

    begin

    s : = s + k mod 10;

    k : = k div 10;

    end;

    if s = n then

    writeln (i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы