Задать вопрос
17 октября, 06:35

Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550). На вход программе подается целое число k (0 k 9999). Выдайте 1 при положительном ответе на вопрос задачи и любое другое целое число - в противном случае.

+5
Ответы (1)
  1. 17 октября, 08:03
    0
    Var

    a:integer;

    begin

    readln (a) ;

    If (a=0) then

    If (a>999) then

    If ((a div 1000) = (a mod 10)) and ((a div 10 mod 10) = (a div 100 mod 10)) then

    writeln ('1')

    else

    writeln ('2')

    else

    If (a>99) and (a<1000) then

    If ((a div 100) = (a mod 10)) then

    writeln ('1')

    else

    writeln ('2')

    else

    If (a>9) and (a<100) then

    If ((a div 10) = (a mod 10)) then

    writeln ('1')

    else

    writeln ('2')

    else

    writeln ('1')

    else

    writeln ('Неправльное число') ;

    end.

    Большое немного решение, может можно и поменьше, но так точно правильно
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550). На вход программе подается целое число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы