Задать вопрос
14 октября, 21:41

Сколько существует невырожденных треугольников периметра с целыми длинами сторонТреугольник со сторонами называется невырожденным если из отрезков длины его можно составить

Входные данные С клавиатуры вводится число

Выходные данные Программа выводит число таких треугольников.

+4
Ответы (1)
  1. 14 октября, 22:40
    0
    Var k, n, a, b, c:integer;

    Begin

    read (n) ;

    for a : = 1 to n do begin

    for b : = a to n - a do begin

    c : = n - a - b;

    if (c>=a) and (c>=b) and (c>0) and (a+b>c) and (a+c>b) and (b+c>a) then

    k : = k + 1;

    end;

    end;

    writeln (k) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сколько существует невырожденных треугольников периметра с целыми длинами сторонТреугольник со сторонами называется невырожденным если из ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы