Задать вопрос
27 марта, 11:34

Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A (N), состоящего из целых чисел. Подсчитать сумму простых чисел, оканчивающихся на 3. Результат вывести на экран.

+2
Ответы (1)
  1. 27 марта, 13:37
    0
    uses crt;

    Var a:array [1 ... 100] of integer; i, n, s: integer;

    Begin

    Writeln ('Введите размер массива') ; readln (n) ;

    For i:=1 to n do begin

    writeln ('Введите элемент массива номер ', i) ; read (a[i]) ;

    end;

    For i:=1 to n do

    if a[i] mod 10=3 then s:=s+a[i];

    Writeln ('Сумма = ', s) ;

    end.

    Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A (N), состоящего из целых чисел. Подсчитать сумму ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы