Задать вопрос
18 июля, 20:04

Напишите программу (Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр: с

+3
Ответы (1)
  1. 18 июля, 21:38
    0
    Var

    n, k, a, i: integer;

    begin

    write ('Введите кол-во чисел: ') ;

    readln (n) ;

    for i:=1 to n do

    begin

    read (a) ;

    if ((a mod 2) = 1) then inc (k) ;

    end;

    write (k) ;

    end.

    С использованием оператора repeat:

    var

    n, k, a, i: integer;

    begin

    write ('Введите кол-во чисел: ') ;

    readln (n) ;

    repeat

    read (a) ;

    if ((a mod 2) = 1) then inc (k) ;

    inc (i) ;

    until i=n;

    write (k) ;

    end.

    n - кол-во чисел, k - кол-во нечётных чисел, a - число

    Все числа вводятся через пробел
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу (Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр: с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы