Задать вопрос
18 июля, 11:14

В паскале составить программу:

определить делимость на 3 для четырехзначного числа.

(думаю, что надо использовать св-во делимости числа: число будет делиться на 3, если сумма цифр этого числа будет делиться на три)

+5
Ответы (1)
  1. 18 июля, 12:31
    0
    var

    a: 1000 ... 9999;

    a1, a2, a3, a4: 0 ... 9; / / Цифры четырехзначного числа

    begin

    writeln ('Введите четырехзначное число') ;

    readln (a) ;

    a1: = a div 1000;

    a2: = (a mod 1000) div 100;

    a3: = (a mod 100) div 10;

    a4: = a mod 10;

    if (a1 + a2 + a3 + a4) mod 3 = 0 then writeln (a, ' делится на 3')

    else writeln (a, ' не делится на 3') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В паскале составить программу: определить делимость на 3 для четырехзначного числа. (думаю, что надо использовать св-во делимости числа: ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы