Задать вопрос
17 августа, 05:10

Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа

+3
Ответы (2)
  1. 17 августа, 07:05
    0
    Program n1;

    var a, kn, kh: longint;

    begin

    kn:=0;

    kh:=0;

    readln (a) ;

    while a>0 do

    begin

    if (a mod 10) mod 2=0 then kh:=kh+1

    else kn:=kn+1;

    a: = a div 10;

    end;

    writeln ('кол-во четных: ', kh) ;

    writeln ('нечетных: ', kn) ;

    end.
  2. 17 августа, 09:07
    0
    Var n, k1, k2:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k1:=0; k2:=0;

    while n>0 do

    begin

    if n mod 2=0 then k1:=k1+1 else k2:=k2+1;

    n:=n div 10;

    end;

    writeln ('Четных цифр - ', k1,', нечетных - ', k2) ;

    end.

    Пример:

    n = 14568

    Четных цифр - 3, нечетных - 2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы