Задать вопрос
2 сентября, 21:54

А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.

Б) Составьте программу, которая заполняет массив В[1 ... 12] случайными целыми числами в диапазоне от 1 до 20 и определяет есть ли в массиве нечетные числа и выводит их на экран.

В) Заполните массив 8 произвольными целыми числами, введя их с клавиатуры и найдите среди них сумму и произведение положительных.

+2
Ответы (1)
  1. 2 сентября, 23:06
    0
    Задача а

    program a; var i:integer; a:array[-5 ... 11] of integer; begin randomize; for i:=1 to 11 do begin a[i]:=random (10) - 5; if a[i] mod 5 = 0 then a[i]:=5 else a[i]:=a[i]*5; write (a[i],' ') ; end; end. Задача б

    program b; var i:integer; a:array[1 ... 12] of integer; begin randomize; for i:=1 to 12 do begin a[i]:=random (20) ; if a[i] mod 2 = 1 then write (a[i],' ') ; end; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Составьте программу, которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на 10.
Ответы (1)
Составьте программу (в паскале), которая заполнит массив a[1 ... 16]случайными целыми числами в диапазоне от - 20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа, кратные 5, а остальные уменьшает на
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)