Задать вопрос
18 июня, 00:13

Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями. 3) Составьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями. 4) Составьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Выведите на экран исходный и полученный массивы.

+3
Ответы (1)
  1. 18 июня, 02:00
    0
    1)

    uses crt;

    const n=8;

    var i:integer;

    a:array[1 ... n] of integer;

    begin

    writeln ('Input elements.') ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    if a[i]<0 then

    write (a[i],' ') ;

    end.

    2)

    uses crt;

    const n=10;

    var i, t:integer;

    a:array[1 ... n] of integer;

    begin

    randomize;

    t:=0;

    write ('Массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (10,1) ;

    write (a[i],' ') ;

    if a[i] mod 2=0 then

    t:=t+1;

    end;

    writeln (#13#10, t) ;

    end.

    3)

    uses crt;

    const n=10;

    var i, sum, t:integer;

    a:array[1 ... n] of integer;

    begin

    randomize;

    sum:=0;

    t:=0;

    write ('Массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (10,1) ;

    write (a[i],' ') ;

    if a[i] mod 2=0 then

    sum:=sum+a[i]

    else

    t:=t+1;

    end;

    writeln (#13#10, sum,' ', t) ;

    end.

    4)

    uses crt;

    const n=10;

    var i:integer;

    a:array[1 ... n] of integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (10,1) ;

    write (a[i],' ') ;

    if a[i] mod 2=0 then

    a[i]:=2*a[i]

    else

    a[i]:=3*a[i];

    end;

    write (#13#10) ;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10 ] случайными целыми числами в диапазоне от 15 до 40, затем элементы с четными индексами удваиваются, а элементы с нечетными индексами утраивает. Выведите на экран исходный и полученный массив.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)