Задать вопрос
1 октября, 13:07

Составить программу, определяющую какая буква слова x (первая или последняя) чаще встречается в слове y. Паскаль!

+5
Ответы (1)
  1. 1 октября, 14:27
    0
    Var x, temp:string;

    first, last:char;

    k1, k2:integer;

    begin

    write ('X = ') ;

    readln (x) ;

    k1:=0;

    k2:=0;

    first:=x[1];

    last:=x[length (x) ];

    temp:=x;

    while (pos (first, temp) >0) do

    begin

    inc (k1) ;

    delete (temp, pos (first, temp),1) ;

    end;

    temp:=x;

    while (pos (last, temp) >0) do

    begin

    inc (k2) ;

    delete (temp, pos (last, temp),1) ;

    end;

    if (k1>k2) then writeln ('First') else

    if (k2>k1) then writeln ('Last') else

    writeln ('Equal') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, определяющую какая буква слова x (первая или последняя) чаще встречается в слове y. Паскаль! ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы